Платежный шлюз — Робокасса для WooCommerce 2.4.0


Встречаем новый стабильный релиз с добавлением функций, оптимизацией производительности и повышением стабильности алгоритмов.
Обновление производится через панель управления и привычными для всех способами.

Изменения в новой версии

Краткий обзор изменений в данной версии по сравнению с предыдущей 2.3 версией.

Новые системные требования

Были повышены системные требования для использования плагина. Теперь нужен WordPress минимум версии 4.2, PHP версии не ниже чем 5.6 и WooCommerce версии не ниже 3.0.

Переход из корзины в Робокассу

Из премиум дополнения перетекла возможность пропустить лишнюю страницу до перехода к оплате.
Многие пользователи путались и не знали что дальше делать. Теперь все должно быть в порядке.
Настройка данной возможности осуществляется в блоке Интерфейс. По умолчанию данная возможность отключена.

Улучшение архитектуры

Была значительно переписана архитектура плагина. Загрузка стала менее требовательной и более расширяемой.

Другие улучшения

Был доработан дизайн настроек. Увеличены шрифты, нормализованы отступы.
Были переписаны тексты для более легкого понимания настроек платежного шлюза.

Заключение

Данный релиз носит по большей части технический характер не добавляющий большое количество функций.
Все ноу-хау функции в данным момент консолидированы в премиум дополнении.
Дополнение скоро тоже обновится и будет доступна оплата без перехода на сайт Робокассы.

Информация по теме